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About This Example 
Let’s jump right in and create a commonly used graph. This example uses many of the key 
features of the SAS ODS Graphics Designer (the designer). Some of these features are described 
in more detail later in the book. For this example, the right amount of description needed to create 
the graph and gain a basic understanding of the process is provided. 
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Let’s make a distribution plot of city gas mileage for all cars in the Sashelp.Cars data set: 

Figure 3.1  Distribution of City Gas Mileage 

 

The graph includes the following features: 

● a histogram of the MPG_CITY variable from the Sashelp.Cars data set 
● overlaid normal density curve and kernel density curve 
● an overlaid fringe plot showing individual observations 
● an inset legend 
● a separate horizontal box plot 
● a common external X axis 
● a graph title 

Create Your Graph 
The following sections walk you through the steps of creating your graph. 

Create a Histogram from the Graph Gallery 
The Graph Gallery is displayed in the work area as shown in Figure 3.2. For graphs that are 
created from the Graph Gallery, placeholder data is assigned to the graph. 

Note: If the Graph Gallery is not displayed, select View ►Graph Gallery. 
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To create the histogram: 

1. On the Basic tab of the Graph Gallery, select the Histogram icon. 
2. Click OK. 

You can also double-click the Histogram icon. For future steps, this book uses the double-click 
action when it is available. 

Figure 3.2  Graph Gallery with Highlighted Histogram and Basic Tab 

 

A graph window is displayed that includes a histogram plot. The Assign Data dialog box for the 
histogram appears, showing the placeholder data assignments. 

 

 



22   SAS ODS Graphics Designer by Example: A Visual Guide to Creating Graphs Interactively 

Figure 3.3  Placeholder Data in the Assign Data Dialog Box 

  

Note: Do not click OK in the Assign Data dialog box. You will change the data assignments 
in the next step. 

The placeholder data enables the designer to show a visual draft of the type of plot that has been 
included in the graph. In this case, the designer uses the HEIGHT variable from the Sashelp.Class 
data set. Using this placeholder data, the designer creates the histogram. 

The Assign Data dialog box is discussed in more detail in Chapter 4. For now, it’s sufficient to 
know that you use this dialog box to change the data assigned to the plot and to the analysis 
variable. 
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Assign Data to the Histogram 
Assign the MPG_CITY variable from the Sashelp.Cars data set to the histogram. 

1. In the Assign Data dialog box, select CARS for Data Set. 
The previous variable, HEIGHT, is not available in the new Sashelp.Cars data set, so the 
Analysis variable setting has been cleared. Because an analysis variable is required, the 
settings for the histogram are not complete. As a result, the plot identifier is shown in red 
and the OK button is not available. 

 
2. Select MPG_CITY for Analysis. 
3. Click OK. 
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The designer creates the graph with a histogram and a placeholder title and footnote. 

Figure 3.4  Histogram with Title and Footnote Placeholders 

 

Note: Your graph might be a different size from the one shown here. For information about 
the graph sizes used in this book, see “Graph Size” in About This Book. 

Change the Title and Remove the Footnote 
Replace the placeholder title and remove the footnote. 

1. Double-click on the placeholder title (“Type in your title”). The placeholder text is 
highlighted: 

 
2. In the text box, enter Distribution of City Mileage. 
3. To remove the footnote, right-click on the placeholder footnote (“Type in your 

footnote”), and select Remove Footnote. 
Your changes are reflected in the graph. 
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Figure 3.5  Graph with New Title 

 

Other actions related to titles and footnotes include the following: 

● To set title properties, right-click on the title, and select Title Properties. The Text 
Properties dialog box is displayed from which you can customize the visual properties 
of the title, such as font, color, and so on. You can do the same for the footnote. 

● You can insert more titles and footnotes using the Insert menu. 

Add Plots to the Graph 
When a graph is displayed in the work area, the Elements pane is active. You can easily add a plot 
from the Elements pane to the graph cell, assuming the plot being added is compatible with the 
existing plot and its axes settings in the graph cell. Plot compatibility is discussed in more detail in 
Chapter 4. 

For this example, let’s add a normal density curve, a kernel density curve, and a fringe plot to the 
graph. These plot types are compatible with the histogram and can be added to this graph. 
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Figure 3.6  Normal Plot in the Elements Pane 

 

1. In the Elements pane, click the Normal icon as shown in Figure 3.6. Drag and drop the 
Normal icon onto the graph. The Assign Data dialog box for a normal density curve is 
displayed. 

 
Note the following in the dialog box: 

◦ Library and Data Set are not available. All the plots in a single cell of a graph must 
use data from the same data set. 
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◦ Fit an existing plot is selected by default. With this option, the normal density curve 
uses the same data settings as the histogram. There is only one plot currently in the 
graph—the histogram. If there were more plots, you would have a choice of which 
plot to use for the fit. 

◦ Because Fit an existing plot is selected, Analysis is not available. The newly added 
plot must use the same data as the histogram. In this example, the normal density 
curve is fitted with the same analysis variable as the histogram. 

2. Click OK. The normal density curve is added to the graph. 
3. In the Elements pane, click the Kernel (kernel density curve) icon. Drag and drop the 

Kernel icon onto the graph.  

 
The Assign Data dialog box for a kernel density curve is displayed. 
This dialog box is similar to the dialog box for the normal density curve. Fit an existing 
plot is selected by default. 

4. Keep the default selections and click OK. The kernel density curve is added to the graph. 
5. In the Elements pane, click the Fringe icon. Drag and drop the Fringe icon onto the 

graph. 

 
The Assign Data dialog box for a fringe plot is displayed. 

6. Select MPG_CITY for X. 

 
4. Click OK. 

The graph is updated with the new plots. 
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Figure 3.7  Graph with Normal Density Curve, Kernel Density Curve, and Fringe Plot 

 

Set Plot Properties 
Figure 3.7 shows the distribution of city mileage for all cars in the Sashelp.Cars data set using a 
histogram, two density curves, and a fringe plot. Because the density curves have the same visual 
properties, it can be difficult to tell which one is normal and which one is kernel. 

To make them clearer, you can modify the visual properties of the kernel density curve. Select the 
kernel density curve, and then change the properties. 

1. In the graph, select the kernel density curve. (The kernel density curve is the taller of the 
two curves.) 
The kernel density curve is selected and in bold. The other plots in the cell are dimmed. 

 



About This Book 

What Does This Book Cover? 
This step-by-step guide is intended to facilitate the creation of graphs using the SAS ODS 
Graphics Designer (the designer). The book describes the graphical interface and features of the 
designer in detail, showing you how to use an interactive application to create the graph that you 
need. Topics are organized by feature, making this an excellent training manual or self-tutorial. 
With this book, you will quickly learn how to create simple or complex graphical views of data 
for analysis. 

This book covers main graphics features, such as single-cell graphs, multi-cell graphs, 
classification panels, data roles, plot types, legends, titles and footnotes, styles, and the visual 
properties of a graph. The book provides details about some advanced features, including 
automatically generated charts, shared-variable graphs, and axis customization. 

This book does not cover all the features of the designer. You are encouraged to refer to the SAS 
ODS Graphics Designer: User’s Guide for complete concepts. 

Is This Book for You? 
This book is useful if you want to create graphs using a simple, interactive application. You do 
not have to be familiar with procedure syntax for creating graphs. 

The first two chapters provide introductory information about ODS graphing software in general 
and the SAS ODS Graphics Designer in particular. If you are familiar with these concepts, you 
can skim the first two chapters and move on to the example in Chapter 3. 

You might also find the book useful if you are an experienced graph programmer who wants to 
perform rapid prototyping of your data using the designer. If you want to learn the basics of the 
Graph Template Language (GTL), the designer can introduce you to GTL code. 

What Are the Prerequisites for This Book? 
The book requires no programming experience, although you should have a basic understanding 
of SAS libraries, data sets, and data roles. 
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What Should You Know about the Examples? 

Software Used to Develop the Book's Content 
This book assumes that the user has the SAS ODS Graphics Designer, Release 9.2 or later. The 
designer is included with SAS 9.2 Phase 2 and later. 

The examples were created and tested using the designer included with the third maintenance 
release for SAS 9.4. 

Platform Used to Create the Examples 
The examples were created in the Windows operating environment. If you are using UNIX, some 
of the designer’s windows might differ from what you see in this book. 

Example Code and Data 
Most of the examples in this book use data sets provided by SAS and available in the Sashelp 
library. These data sets include CARS, HEART, and a few others. Sometimes, the number of 
classifiers was reduced to fit the graph in a restricted space. As a result, modified data sets were 
used that include a subset of data from the original Sashelp data sets. In addition, custom data sets 
were needed for an example graph. 

When an example requires you to run SAS code, that code is available from: 

● the appendix of this book 
● http://support.sas.com/publishing/authors/matange.html 
● http://support.sas.com/publishing/authors/bottitta.html    

Graph Size 
The default setting for graph size in the designer is 640px by 480px (pixels). This setting is 
specified in the Preferences dialog box along with other settings. You can modify these settings 
by selecting Tools ►Preferences. 

For this book, the default height is 350px to fit in the available space. When graphs are reduced in 
size, smaller graphs might have scaled-down font sizes. Also, their numeric axes might display 
tick values differently. As a result, the graphs that you generate from the examples will not always 
look identical to the graphs that are shown in the figures. However, both graphs will accurately 
represent the data. 

Styles 
The graphs created by the designer use the LISTING style by default. This style and other 
available styles are optimized for full-color output. Most of the graph examples in this book use 
the default LISTING style. 

  

http://support.sas.com/publishing/authors/matange.html
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Additional Help 
Although this book illustrates many analyses regularly performed in businesses across industries, 
questions specific to your aims and issues might arise. To fully support you, SAS Institute and 
SAS Press offer you the following help resources: 

● For questions about topics covered in this book, contact the author through SAS Press: 

◦ Send questions by email to saspress@sas.com; include the book title in your 
correspondence. 

◦ Submit feedback on the author’s page at http://support.sas.com/author_feedback. 
● For questions about topics in or beyond the scope of this book, post queries to the 

relevant SAS Support Communities at https://communities.sas.com/welcome. 
● SAS Institute maintains a comprehensive website with up-to-date information. You can 

get technical support, find resources for a product, and search for information at 
http://support.sas.com/. 

We Want to Hear from You 
SAS Press books are written by SAS Users for SAS Users. We welcome your participation in 
their development and your feedback on SAS Press books that you are using. Please visit 
https://support.sas.com/publishing to do the following: 

● Sign up to review a book 
● Recommend a topic 
● Request authoring information 
● Provide feedback on a book 

Do you have questions about a SAS Press book that you are reading? Contact the author through 
saspress@sas.com or https://support.sas.com/author_feedback.  

SAS has many resources to help you find answers and expand your knowledge. If you need 
additional help, see our list of resources: https://support.sas.com/publishing.  

  

mailto:saspress@sas.com
http://support.sas.com/publishing/bbu/companion_site/info.html
https://communities.sas.com/welcome
http://support.sas.com/
https://support.sas.com/publishing
mailto:saspress@sas.com
https://support.sas.com/author_feedback
https://support.sas.com/publishing
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